You may experience compatibility issues when you try to use Windows Services for UNIX 3.5 on a Windows Vista-based computer

You may experience compatibility issues when you try to use Windows Services for UNIX 3.5 on a Windows Vista-based computer

Article ID : 932244
Last Review : January 31, 2007
Revision : 2.0
On This Page

INTRODUCTION

This article describes compatibility issues that you may experience when you try to use Microsoft Windows Services for UNIX 3.5 on a Windows Vista-based computer.

Back to the top

MORE INFORMATION

You may experience one or more of the following issues when you try to use Windows Services for UNIX 3.5 together with Windows Vista.

Note Because of compatibility issues that exist between Windows Services for UNIX 3.5 and the Subsystem for UNIX-based Applications (SUA) component that is available in Windows Vista, we do not support Windows Services for UNIX 3.5 when it is installed on a Windows Vista-based computer.

Back to the top

Issue 1: Upgrade support

We do not support upgrading a computer that is running Windows Services for UNIX 3.5 to Windows Vista.

Symptom

When you try to upgrade a computer that is running Windows Services for UNIX 3.5 to Windows Vista, the upgrade operation may be unsuccessful.

Workaround

To work around this issue, remove Windows Services for UNIX 3.5 before you upgrade the computer to Windows Vista.

Important Back up the files that you want to save before you remove Windows Services for UNIX 3.5.

Back to the top

Issue 2: You cannot install Windows Services for UNIX 3.5 on a computer that is running Windows Vista

Symptom

When you run the Windows Services for UNIX 3.5 Setup program to install Windows Services for UNIX 3.5 on a computer that is running Windows Vista, the installation may be unsuccessful.

Workaround

To work around this issue, use the following Windows Vista optional components to provide Windows Services for UNIX functionality:

• Subsystem for UNIX-based Applications
• Services for NFS

These components are available in the following editions of Windows Vista:

• Windows Vista Enterprise
• Windows Vista Ultimate

Back to the top

Issue 3: Windows Services for UNIX 3.5 does not work correctly on a computer that is running Windows Vista

Symptom

If you install Windows Services for UNIX 3.5 on a Windows Vista-based computer, Windows Services for UNIX 3.5 may not work as expected.

This issue occurs because Windows Services for UNIX 3.5 does not work correctly on a computer that is running Windows Vista.

Workaround

To work around this issue, use the following Windows Vista optional components to provide Windows Services for UNIX functionality:

• Subsystem for UNIX-based Applications
• Services for NFS

These components are available in the following editions of Windows Vista:

• Windows Vista Enterprise
• Windows Vista Ultimate

Back to the top

Functionality comparison information

The following table lists the Windows Services for UNIX 3.5 features together with the corresponding Windows Vista components that provide similar functionality:

Windows Services for UNIX component Windows Vista component
Interix Subsystem Subsystem for UNIX-based Applications
Client for NFS Services for NFS
Utilities, Interix GNU Components and Interix Software Development Kit (SDK) Components that provide similar functionality are available as an add-in pack for Windows Vista. For more information, see the References section.
Server for NFS
Gateway for NFS
Server for PCNFS
User Name Mapping
Password Synchronization
Server for NIS
Active State Perl
Not available in Windows Vista

Back to the top

REFERENCES

Utilities and SDK for Subsystem for UNIX-based Applications is an add-in pack for the Subsystem for UNIX-based Applications component in Windows Vista, to obtain the Utilities and SDK for Subsystem for UNIX-based Applications add-in pack, visit the following Microsoft Web site:

http://www.microsoft.com/downloads/details.aspx?FamilyId=93FF2201-325E-487F-A398-EFDE5758C47F (http://www.microsoft.com/downloads/details.aspx?FamilyId=93FF2201-325E-487F-A398-EFDE5758C47F)

Note We recommend that you install the Subsystem for UNIX-based Applications component in Windows Vista before you install this add-in pack.

Back to the top


APPLIES TO
• Microsoft Windows Services for UNIX 3.5
• Windows Vista Ultimate
• Windows Vista Enterprise

Back to the top

Keywords: 
kbinfo kbhowto KB932244

Back to the top

 

Microsoft Knowledge Base Article

This article contents is Microsoft Copyrighted material.
Microsoft Corporation. All rights reserved. Terms of Use | Trademarks


You can follow any responses to this entry through the RSS 2.0 feed. You can leave a response, or trackback from your own site.

AddThis Social Bookmark Button

Leave a Reply

*
To prove that you're not a bot, enter this code
Anti-Spam Image