You cannot start the Microsoft Exchange Transport service on an Exchange Server 2007 Hub server

You cannot start the Microsoft Exchange Transport service on a Microsoft Exchange Server 2007 Hub server. When this occurs, the following error message is logged the Application event log:

Event Type: Error
Event Source: MSExchangeTransport
Event Category: Routing
Event ID: 5023
Description:
A transient configuration error was detected while the routing configuration was loading. Exception details: The local server isn’t a member of any routing group. : Microsoft.Exchange.Transport.Categorizer.TransientRoutingException: The local server isn’t a member of any routing group. At Microsoft.Exchange.Transport.Categorizer.RoutingGroupRelayMap.ValidateConfig(ExchangeTopology topology, RawRoutingConfigData rawConfigData, DateTime timestamp)at Microsoft.Exchange.Transport.Categorizer.RoutingTables.ValidateConfig(RawRoutingConfigData rawConfigData)at Microsoft.Exchange.Transport.Categorizer.RoutingTables.PopulateTables(RawRoutingConfigData rawConfigData)


CAUSE

This issue occurs because there is no value for the msExchHomeRoutinggroup attribute on the Exchange 2007 Hub server object in Active Directory directory service.


RESOLUTION

To resolve this issue, follow these steps:

1. Open the ADSIEdit tool, and connect to the configuration context.
2. Locate the Exchange Administrative Group object.
3. Open Properties for the Exchange Routing Group object, and copy the distinguishedName value.
4. Locate the Servers object in Exchange Administrative Group.
5. Select Properties for the Exchange 2007 Hub server, and find the msExchHomeRoutingGroup attribute
6. Open the msExchHomeRoutingGroup attribute, and enter the distinguishedName value that you copied in step 3 for the Exchange 2007 Routing Group.
7. Verify that the Exchange 2007 server is visible in the Exchange Routing Group in Exchange System Manager.
8. Restart the Microsoft Exchange Transport service on the Exchange 2007 Hub server.



APPLIES TO
Microsoft Exchange Server 2007 Standard Edition
Microsoft Exchange Server 2007 Enterprise Edition
Microsoft Exchange Server 2007 Service Pack 1

——————————————–

Microsoft Knowledge Base Article

This article contents is Microsoft Copyrighted material.
Microsoft Corporation. All rights reserved. Terms of Use | Trademarks

 


You can follow any responses to this entry through the RSS 2.0 feed. You can leave a response, or trackback from your own site.

AddThis Social Bookmark Button

2 Responses to “You cannot start the Microsoft Exchange Transport service on an Exchange Server 2007 Hub server”

  1. just enable IPV6

  2. Indeed this is the fix

Leave a Reply

*
To prove that you're not a bot, enter this code
Anti-Spam Image