VPN connection fails on Windows Vista client: Error 609: A device type was specfied that does not exit

VPN connection fails on Windows Vista client: Error 609: A device type was specfied that does not exit

Article ID : 953795
Last Review : May 30, 2008
Revision : 1.0
Source: Microsoft Support

Back to the top

RAPID PUBLISHING

RAPID PUBLISHING ARTICLES PROVIDE INFORMATION DIRECTLY FROM WITHIN THE MICROSOFT SUPPORT ORGANIZATION. THE INFORMATION CONTAINED HEREIN IS CREATED IN RESPONSE TO EMERGING OR UNIQUE TOPICS, OR IS INTENDED SUPPLEMENT OTHER KNOWLEDGE BASE INFORMATION.

Back to the top

Result

On a Windows Vista computer, you are unable to establish a connection to the VPN server. The following symptoms occur:

1. After you enter the username and password for the VPN connection, it tries to connect for a while then the error message occurs:

Failed to connect to <connectionname>

2. If you create a new VPN connection, it shows as a Dial-up connection.

3. This event is logged in the Application event log.

Log Name:      Application
Source:        RasClient
Date:          mm/dd/yyyy <time>
Event ID:      20227
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      <computername>
Description:
CoID={6ADB8BA2-868E-4406-88CF-FFFBFDAD6684}: The user <domain> <user> dialed a connection named <ConnectionName> which has failed. The error code returned on failure is 609.

Back to the top

Cause

This may occur when the VPN WAN miniport is corrupted or not present.

Back to the top

Resolution

To resolve this issue, uninstall and reinstall the miniports manually. To do so, follow the steps below:

1. Click Start>All Programs>Accessories and click Command Prompt.

2. In the Command prompt, type the following commands one by one and press Enter after each one.

Netcfg -u MS_L2TP
Netcfg -u MS_PPTP
Netcfg -l %windir% inf netrast.inf -c p -i MS_PPTP
Netcfg -l %windir% inf netrast.inf -c p -i MS_L2TP

NOTE: When prompted by User Account Control, click Continue.

Back to the top

More Information

This problem happens if the virtual WAN miniports for PPTP/L2TP are not installed or corrupted.

You can verify if this is the issue by following the below steps:

1. Open Device Manager (Start -> Run -> devmgmt.msc).
2. Click on ‘View’ in the toolbar and select ‘Show hidden devices’
3. Expand the machine name node.
4. Under ‘Network Adapters’ node, see if WAN Miniport (PPTP) and WAN Miniport (L2TP) are present. If either of them is not present then you are facing the issue mentioned in this article.

Back to the top

DISCLAIMER

MICROSOFT AND/OR ITS SUPPLIERS MAKE NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY, RELIABILITY OR ACCURACY OF THE INFORMATION CONTAINED IN THE DOCUMENTS AND RELATED GRAPHICS PUBLISHED ON THIS WEBSITE (THE “MATERIALS”) FOR ANY PURPOSE. THE MATERIALS MAY INCLUDE TECHNICAL INACCURACIES OR TYPOGRAPHICAL ERRORS AND MAY BE REVISED AT ANY TIME WITHOUT NOTICE.

TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, MICROSOFT AND/OR ITS SUPPLIERS DISCLAIM AND EXCLUDE ALL REPRESENTATIONS, WARRANTIES, AND CONDITIONS WHETHER EXPRESS, IMPLIED OR STATUTORY, INCLUDING BUT NOT LIMITED TO REPRESENTATIONS, WARRANTIES, OR CONDITIONS OF TITLE, NON INFRINGEMENT, SATISFACTORY CONDITION OR QUALITY, MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE, WITH RESPECT TO THE MATERIALS.

Back to the top


APPLIES TO
• Windows Vista Enterprise
• Windows Vista Business
• Windows Vista Ultimate

Back to the top

Keywords: 
kbnomt kbrapidpub KB953795

Back to the top

 

Microsoft Knowledge Base Article

This article contents is Microsoft Copyrighted material.
Microsoft Corporation. All rights reserved. Terms of Use | Trademarks


You can follow any responses to this entry through the RSS 2.0 feed. You can leave a response, or trackback from your own site.

AddThis Social Bookmark Button

Leave a Reply

*
To prove that you're not a bot, enter this code
Anti-Spam Image