An Audio Streaming Input and Output (ASIO) driver may not work correctly on a Windows Vista-based computer

On a Windows Vista-based computer, an Audio Streaming Input and Output (ASIO) driver may not work correctly. When this problem occurs, you experience the following symptoms.

 

Symptom 1

When the ASIO driver calls the GetLinkPositionRegister routine that is provided in the Microsoft high-definition audio device driver interface (DDI), the GetLinkPositionRegister routine always returns 0 for the current direct memory access (DMA) position. In this situation, the ASIO driver may be unable to initialize. This symptom occurs only when certain hardware audio chipsets are installed. For example, this symptom occurs on a computer that has the ATI SB460 Southbridge chipset installed.

 

Symptom 2

An application can use the AUDCLNT_STREAMFLAGS_EVENTCALLBACK flag to open an exclusive-mode audio stream in pull mode. In this situation, the audio engine should signal an event that is provided by the application to indicate that the audio buffer is ready for processing. However, the audio engine does not correctly signal the event on a Windows Vista-based computer.

 

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next service pack that contains this hotfix.

To resolve this problem, submit a request to Microsoft Online Customer Services to obtain the hotfix. To submit an online request to obtain the hotfix, visit the following Microsoft Web site:

http://go.microsoft.com/?linkid=6294451 (http://go.microsoft.com/?linkid=6294451)

Note If additional issues occur or any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. To create a separate service request, visit the following Microsoft Web site:

http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

 

APPLIES TO
Windows Vista Ultimate
Windows Vista Home Premium
Windows Vista Home Basic
Windows Vista Enterprise
Windows Vista Business
Windows Vista Business 64-bit Edition
Windows Vista Ultimate 64-bit Edition
Windows Vista Home Premium 64-bit Edition
Windows Vista Home Basic 64-bit Edition
Windows Vista Enterprise 64-bit Edition

——————————————–

Microsoft Knowledge Base Article

This article contents is Microsoft Copyrighted material.
Microsoft Corporation. All rights reserved. Terms of Use | Trademarks

 


You can follow any responses to this entry through the RSS 2.0 feed. You can leave a response, or trackback from your own site.

AddThis Social Bookmark Button

Leave a Reply

*
To prove that you're not a bot, enter this code
Anti-Spam Image